Panzura Security Advisory PZOS-2014-004

Issue Date:  09/25/2014
Updated Date:  09/29/2014
Title:  GNU-Bash Vulnerability
Classification:  Low
Status:  Closed
Affected Products:  PZOS – 5.5.0.0 or Below

Summary

The NIST National Cyber Awareness System announced a vulnerability discovered in GNU-Bash in version 4.3 and all prior versions. Additional information is available in CVE-2014-6271 available here: https://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2014-6271

Details

As noted at the above URL:

GNU Bash through 4.3 processes trailing strings after function definitions in the values of environment variables, which allows remote attackers to execute arbitrary code via a crafted environment, as demonstrated by vectors involving the ForceCommand feature in OpenSSH sshd, the mod_cgi and mod_cgid modules in the Apache HTTP Server, scripts executed by unspecified DHCP clients, and other situations in which setting the environment occurs across a privilege boundary from Bash execution, aka “ShellShock”.

Panzura technical staff has conducted a thorough review of the PZOS code base and concluded Panzura Cloud Controllers are not susceptible to this vulnerability. Methods for preventing the exploitation of this vulnerability already exist within Panzura’s PZOS, which powers all Panzura products. As such, no workarounds or updates are necessary. Based on this analysis, the classification has been revised from Moderate to Low.

Resolution

Panzura software is not at risk from this vulnerability.

Back to Advisories List